Page 47 of 50

Re: C++ -kysymykset

Posted: Mon Nov 21, 2011 7:09 pm
by MaGetzUb
No tulipa p*rullinen ongelma... SFML ei toimi joillakin nykyisillä ATI(amd?):n ajureilla... >:( Onko kellään ehdotuksia kuinka saisin SFML:n toimimaan? :)

Re: C++ -kysymykset

Posted: Mon Nov 21, 2011 8:37 pm
by Feuer
Mikä IDE, mikä versio kirjastosta?

Re: C++ -kysymykset

Posted: Mon Nov 21, 2011 8:42 pm
by MaGetzUb
Feuer wrote:Mikä IDE, mikä versio kirjastosta?
Code::Blocks, SFML 1.6.. Oon googlannu, mutta ei oo löytäny pikaasesti kyl mitää apua.. :/

Re: C++ -kysymykset

Posted: Mon Nov 21, 2011 8:56 pm
by Feuer
Kokeile jos tästä olis apua. Jännä ettei minulla 4850:n kanssa ole ollut mitään ongelmia sfml:n kanssa :P
EDIT:

Dimple wrote: Muistaakseni ongelma korjaantuu, kun linkittää staattisesti. Toinen vaihtoehto on siirtyä käyttämään SFML 2:sta, siihen on korjattu muitakin bugeja.
Sen takia ei ole ollut ongelmaa. Aina linkittänyt tuon kirjaston staattisesti, ja nyt on käytössä kakkosversio.[/edit]

Re: C++ -kysymykset

Posted: Mon Nov 21, 2011 9:19 pm
by MaGetzUb
Feuer wrote:Kokeile jos tästä olis apua. Jännä ettei minulla 4850:n kanssa ole ollut mitään ongelmia sfml:n kanssa :P
Jos 4850 viittaa näytönohjaimeen, niin minulla on HD Radeon 5650m..
EDIT:

Jos ymmärsin oikein niin tuon jonkun .dll tiedoston pitää laittaa samaan kansioon, mistä ajetaan? Ei toiminut ainakaan tuolla tyllillä minulla..


Re: C++ -kysymykset

Posted: Tue Nov 22, 2011 7:29 pm
by Dimple
Muistaakseni ongelma korjaantuu, kun linkittää staattisesti. Toinen vaihtoehto on siirtyä käyttämään SFML 2:sta, siihen on korjattu muitakin bugeja.

Itselläni on sama näytönohjain ja oli sama ongelma.

Re: C++ -kysymykset

Posted: Fri Nov 25, 2011 5:22 pm
by MaGetzUb
Miksi ihmeessä SFML 2.0:n Sprite luokkalla ei ole enää SetImage komentoa? Ehkä typerin asia, mikä ollaan 2.0:a poistettu... :evil:

Re: C++ -kysymykset

Posted: Sat Nov 26, 2011 12:46 am
by temu92
Dokumentaatiosta kannattaa kattella muuttuneita funktionimiä: http://www.sfml-dev.org/documentation/2.0/

Ilmeisesti spriteille imagen sijaan ladataankin texture ja käytetään SetTexture-funtkiota sen asettamiseen.

Re: C++ -kysymykset

Posted: Sun Nov 27, 2011 6:16 pm
by Latexi95
Tallentaako OpenGL:n display list (glNewList) shadereiden vaihdoksen? Uniform arvojen asetuksen se ainakin ymmärtääkseni tallentaa. Eli voinko olettaa OpenGL:n piirtävän oikein jos kesken listan vaihdan käytettävää shaderia?

Re: C++ -kysymykset

Posted: Sun Nov 27, 2011 8:11 pm
by koodaaja
Periaatteessa se tallentaa kaikki OpenGL:n piirtokomennot joten kyllä. Täyden varmuuden saa varmaan helpoimmin testaamalla.

Re: C++ -kysymykset

Posted: Mon Nov 28, 2011 8:40 pm
by esa94
Latexi95 wrote:Tallentaako OpenGL:n display list (glNewList) shadereiden vaihdoksen? Uniform arvojen asetuksen se ainakin ymmärtääkseni tallentaa. Eli voinko olettaa OpenGL:n piirtävän oikein jos kesken listan vaihdan käytettävää shaderia?
Eihän listoja kuulu käyttää

Re: C++ -kysymykset

Posted: Mon Nov 28, 2011 9:00 pm
by Latexi95
esa94 wrote: Eihän listoja kuulu käyttää
Jaa? Mitäs sitten ajattelit? VBO:ta tietysti voi käyttää (ja käytänkin)...

Re: C++ -kysymykset

Posted: Mon Nov 28, 2011 9:21 pm
by esa94
Latexi95 wrote:
esa94 wrote: Eihän listoja kuulu käyttää
Jaa? Mitäs sitten ajattelit? VBO:ta tietysti voi käyttää (ja käytänkin)...
VBO on ainoa jota tuetaan.

Siis kirjaimellisesti. Kaikki muu on käytännössä deprekoitu.

Re: C++ -kysymykset

Posted: Mon Nov 28, 2011 9:51 pm
by Latexi95
esa94 wrote: VBO on ainoa jota tuetaan.

Siis kirjaimellisesti. Kaikki muu on käytännössä deprekoitu.
Juu, voipi olla.

Hankalaa kun OpenGL:ssä ei ole oikein selkeitä ohjeita. Suurin osa on vanhentuneita ja jopa OpenGL:n omilla sivulla on jatkuvasti ristiriitaista tietoa, ja extension systeemi on todella sekava...

Re: C++ -kysymykset

Posted: Tue Nov 29, 2011 10:58 pm
by Sami345
esa94 wrote:VBO on ainoa jota tuetaan.

Siis kirjaimellisesti. Kaikki muu on käytännössä deprekoitu.
Ilmeisesti oletat tässä, että käytetään OpenGL:n versiota 3.x tai uudempaa? Lisäksi tuki vanhoille OpenGL:n versioille tulee säilymään vielä pitkään. Laitteistovalmistajat eivät voi yksinkertaisesti jättää niitä pois, koska se estäisi monien varsinkin vanhojen pelien toiminnan. Myös uusien pelien, jotka on suunniteltu toimimaan myös vanhalla laitteistolla toiminta saattaisi vaarantua.

Re: C++ -kysymykset

Posted: Wed Nov 30, 2011 7:58 pm
by esa94
Sami345 wrote:
esa94 wrote:VBO on ainoa jota tuetaan.

Siis kirjaimellisesti. Kaikki muu on käytännössä deprekoitu.
Ilmeisesti oletat tässä, että käytetään OpenGL:n versiota 3.x tai uudempaa? Lisäksi tuki vanhoille OpenGL:n versioille tulee säilymään vielä pitkään. Laitteistovalmistajat eivät voi yksinkertaisesti jättää niitä pois, koska se estäisi monien varsinkin vanhojen pelien toiminnan. Myös uusien pelien, jotka on suunniteltu toimimaan myös vanhalla laitteistolla toiminta saattaisi vaarantua.
Totta kai oletan. Yhteensopivuuskaan ei ole missään nimessä ongelma, jokainen markkinoilla vähänkään asiansa osaava näytönohjain kun tukee bufferiobjekteja ynnä shadereita, joskin jonkun vuoden takaiset tietokoneet saattavat vaatia vanhemman version shaderit toimiakseen.

Eihän vanhoja versioita ole mitään syytä käyttää.

Re: C++ -kysymykset

Posted: Wed Nov 30, 2011 10:57 pm
by koodaaja
Itse ainakin näen 1.4:n parhaana vaihtoehtona miniläppärikoodailuun kun ei tämä uudempiakaan tue. Ei tämmöisiä ole toki kovin raskaan grafiikan piirtämiseen tarkoitettukaan, mutta sehän on jo itsessään painava syy kokeilla laitteen rajoja :)

Re: C++ -kysymykset

Posted: Fri Dec 02, 2011 10:01 pm
by JATothrim
Jos haluaa, että ohjelma toimii takuuvarmasti joka koneessa, niin OpenGL 1.1 konteksti (VertexArrayt) eikä yhtään GL_XXX_ extensionia. (WGL_ ja GLX_ extensionit tarvitaan tietty silti)
Jos taas haluaa repiä näyttiksestä kaiken irti, hyvä tie on aloittaa OpenGL +3.0 kontekstilla, joka pudottaa depredikoidut ominaisuudet pois ja vasta sitten kahlata extension viidakon läpi glew:llä.
Syy miksi jaan näin raa'asti on juuri se, että extensionien kirjo OpenGL 1.1 - 3.0 versioiden välillä on hurja. Shaderistakin oli kahdet yhteensopimattomat eri versiot, kun ne otettiin mukaan 1.5-2.0 vaiheessa. (Cg ja GLSL) : /
1.1 - 2.1 raudan tukeminen on tietty sitten se kolmas ja vaikein case. ;)

Re: C++ -kysymykset

Posted: Fri Dec 02, 2011 11:06 pm
by Latexi95
JATothrim wrote:Jos haluaa, että ohjelma toimii takuuvarmasti joka koneessa, niin OpenGL 1.1 konteksti (VertexArrayt) eikä yhtään GL_XXX_ extensionia. (WGL_ ja GLX_ extensionit tarvitaan tietty silti)
Jos taas haluaa repiä näyttiksestä kaiken irti, hyvä tie on aloittaa OpenGL +3.0 kontekstilla, joka pudottaa depredikoidut ominaisuudet pois ja vasta sitten kahlata extension viidakon läpi glew:llä.
Syy miksi jaan näin raa'asti on juuri se, että extensionien kirjo OpenGL 1.1 - 3.0 versioiden välillä on hurja. Shaderistakin oli kahdet yhteensopimattomat eri versiot, kun ne otettiin mukaan 1.5-2.0 vaiheessa. (Cg ja GLSL) : /
1.1 - 2.1 raudan tukeminen on tietty sitten se kolmas ja vaikein case. ;)
Juu. Ehdottomasti kannattaa tehdä selkeä jako, ja minäkin kyllä suosittelisin tuota OpenGL 3.0 rajapyykiksi varsinkin jos aikoo käyttää glsl shadereita. OpenGL 3.0:ssa tullut glsl 1.3 eroaa reilusti aiemmasta 1.2:sta. Kun etsii tietoa glsl shadereista niin kannattaa varmistaa että koskeeko tieto 1.3:sta ja sitä myöhempiä versioita vai aiempia versioita. Tuo aiheuttaa helposti sekaannusta.

Re: C++ -kysymykset

Posted: Sun Dec 04, 2011 8:22 pm
by esa94
JATothrim wrote:Shaderistakin oli kahdet yhteensopimattomat eri versiot, kun ne otettiin mukaan 1.5-2.0 vaiheessa. (Cg ja GLSL) : /
Cg tosin toimii vain nVIDIAn raudalla kunnolla kun se on niille kehitetty

GLSL on lähestulkoon aina parempi waihtoehto